Discussion Board

|Discussion Board
2019-05-15T15:44:47+00:00

Welcome to the CDG Discussion board

CDG members need to be logged-in to view member only areas. Non-members are welcome to register in order to create or, reply to topics in the public areas.

Notifications
Clear all

VisBot glitch

 

(@john-cordingley)
Member
Joined: 6 years ago
Posts: 1044
Topic starter  

Keen eyed users of this site may have noticed that the VisBot stopped displaying data after Monday 9th May. Also, for some reason, whenever Richard K submits a zero rainfall reading it gets displayed as "-0.5 mm". I mentioned this to Jason Pepper during the week and he's looking at it. 

Please could those who submit data daily keep sending in the information meanwhile, so it's all there to be displayed once the problems sorted?

Also, we need to get a rain gauge from the Dales to Mendip for Rob Harper. If anyone's travelling between the Dales & Mendip and can help, please could you contact me separately? Thanks.


Quote
(@john-cordingley)
Member
Joined: 6 years ago
Posts: 1044
Topic starter  

In case it helps folks to know, both Richard Kavanagh and I had 11 mm in our gauges this morning in the Dales (Tuesday 17th May) and the vis has been put back again. Richard says the Ribble is brown ale today.


ReplyQuote
(@john-cordingley)
Member
Joined: 6 years ago
Posts: 1044
Topic starter  

Yay - we've got our VisBot back; many thanks to Jason P for fixing it. 

There's still the weird anomaly of Richard's zero readings being displayed as "-0.5 mm", in case anyone can look into this . . . . . ?


ReplyQuote
(@ben-wright)
Member
Joined: 6 years ago
Posts: 181
 

Sorry - this was my fault. There is a data processing script that runs on a Raspberry Pi in my living room - the ethernet cable fell out of it, so it stopped working. Once I'd plugged it back in and restarted it, it was all working fine. This was running on the server the new membership database was on, but due to the cost this was decommissioned. We probably should find a better solution for this, so it doesn't happen again.

The reason for the -0.5mm rainfall figure is so that people can tell the difference on the graphs between a null value and 0mm rainfall (which I feel is very very important) - hence the processing script replaces the 0 with a small negative value, so there is a very small blue bar under the axis. The table on the left should omit this processed data (it does for the other contributors), but for some reason the website keeps on resetting Richards table and shows this rainfall_fixed column. I did point this out around a month ago, but I'm guessing Jason hasn't had the time to fix it yet.

Hope that makes sense!

B

 


ReplyQuote
(@john-cordingley)
Member
Joined: 6 years ago
Posts: 1044
Topic starter  

Thanks Ben,

Most of that went right over my head but I'm sure Jason will understand.

Yes, fully agree there needs to be a way to differentiate between a zero reading and an absence of a reading.


ReplyQuote
Share:

A read-only archive of old forum posts can be viewed here

Diary Dates